We’ve had a handful of reports where OS X shows this error dialog when the user tries to open Dragonframe:mac warning: Dragonframe cannot be opened because of a problem

If you look at the report, it says something like this:

Dyld Error Message:

Library not loaded: @executable_path/../Frameworks/libavcodec.dylib

Referenced from: /Applications/Dragonframe/Dragonframe.app/Contents/MacOS/Dragonframe

Reason: Incompatible library version: Dragonframe requires version 55.0.0 or later, but libavcodec.dylib provides version 52.0.0

The issue is caused by some other program setting a global library path, which is a very bad thing.

There may be more than one program that does this, but we’ve found that older versions of an application called “Tracker” does this. If you installed Tracker version 4.84 or older, you should uninstall it and then install version 4.85 or newer to resolve the issue.

If you’ve never installed tracker, look for “DYLD_LIBRARY_PATH” in your environment plist file:

Open a Terminal (Applications : Utilities) and type:

sudo open ~/.MacOSX/environment.plist

It will ask for your password. This is your machine password that you use to log in. It does not show it to you as you type.

In the editor that opens, remove anything that says “DYLD_LIBRARY_PATH”.

Note: This might require XCode. If you don’t have it, you may alternatively need to just remove this file, like this:

sudo rm ~/.MacOSX/environment.plist