Yes. Dragonframe 4.2 and newer have been tested with macOS Catalina, and support all of Apple’s new security requirements.

We have no plans to update Dragonframe 3 to support Catalina, due to continuous graphics driver changes from Apple.